Please help... 

I am binding 16500 data records (SchemaDataDesigner / installation data). 
I am changed the setting "Maximum quantity of data strings to be bound to package"
But I am getting an error:


The incoming request has too many parameters. The server supports a maximum of 2100 parameters. Reduce the number of parameters and resend the request.


6 комментариев

Hi! Try to separate on a few data bindings, where each binding cosist of 2100 records 

Нигрескул Алексей,


Hello Alexey! I need to bind a large lookup of 65 000 entries rows, I divide it into 12 parts by the type/value of one field, but the largest part is 16 500 entries. Since splitting 65 000 / into 2100 limit = 30 parts, which is not convenient... Is it possible to increase the limit to 2100 row?

Hello! If it's a new records and you need only insert data, you can generate insert scripts and execute them on your db instance. But it's a not best practice.

Did you try change sysstem setting with code MaxPackageSchemaDataRowsCount?

Hello! I am change system setting MaxPackageSchemaDataRowsCount to 20 000. But it did not help. I wrote at the beginning 1st message that I tried to change this setting. Please help....


You cannot change the number of parameters that can be bound in a Date element.

Please use other data import tools.

For example, you can use import from Excel:

You can also import data using SQL queries:

Показать все комментарии